EC-CUBEの管理画面でオーナーズストアからプラグインをインストールしようとするとUnable to launch a new process.と言われてシステムエラー。(Amazon Linux2)

プラグイン内でcomposerのライブラリをrequireで使っているから?

"require":{"ec-cube\/plugin-installer":"~0.0.8","pear\/pear-core-minimal":"^1.10.0alpha2","pear\/archive_tar":"^1.4.3","wapmorgan\/unified-archive":"^0.0.3","nobuhiko\/bulk-insert-query":"*"}

MacのDocker Desktopでは問題なくインストールできたが、Amazon Linux2でうまくいかないのは何かサーバー設定が違うのだろうか。要調査。

ちなみにbin/console eccube:composer:require ec-cube/datamigration4を使えばAmazon Linux2 上のLamp環境でも問題なくインストールできる。だが、管理画面上からのインストールができなかった。

発生したログは下記の通り。

[Eccube\Log\Logger:log:64] – システムエラーが発生しました。 [“\nIn Process.php line 342:\n                                   \n  Unable to launch a new process.  \n                                   \n\n”,”/var/www/html/src/Eccube/Service/Composer/ComposerApiService.php”,319,”#0 /var/www/html/src/Eccube/Service/Composer/ComposerApiService.php(245): Eccube\\Service\\Composer\\ComposerApiService->runCommand(Array, Object(Symfony\\Component\\Console\\Output\\BufferedOutput), false)\n#1 /var/www/html/src/Eccube/Service/Composer/ComposerApiService.php(363): Eccube\\Service\\Composer\\ComposerApiService->execConfig(‘platform.php’, Array)\n#2 /var/www/html/src/Eccube/Service/Composer/ComposerApiService.php(296): Eccube\\Service\\Composer\\ComposerApiService->init()\n#3 /var/www/html/src/Eccube/Service/Composer/ComposerApiService.php(83): Eccube\\Service\\Composer\\ComposerApiService->runCommand(Array)\n#4 /var/www/html/src/Eccube/Service/Composer/ComposerApiService.php(207): Eccube\\Service\\Composer\\ComposerApiService->execInfo(‘ec-cube/plugin-…’, ‘~0.0.8’)\n#5 /var/www/html/src/Eccube/Service/Composer/ComposerApiService.php(211): Eccube\\Service\\Composer\\ComposerApiService->foreachRequires(‘ec-cube/plugin-…’, ‘~0.0.8’, Object(Closure), ‘eccube-plugin’, 1)\n#6 /var/www/html/src/Eccube/Service/PluginService.php(798): Eccube\\Service\\Composer\\ComposerApiService->foreachRequires(‘ec-cube/DataMig…’, ‘~0.0.8’, Object(Closure), ‘eccube-plugin’)\n#7 /var/www/html/src/Eccube/Controller/Admin/Store/OwnerStoreController.php(232): Eccube\\Service\\PluginService->getPluginRequired(Array)\n#8 /var/www/html/vendor/symfony/http-kernel/HttpKernel.php(151): Eccube\\Controller\\Admin\\Store\\OwnerStoreController->doConfirm(Object(Symfony\\Component\\HttpFoundation\\Request), ‘1804’)\n#9 /var/www/html/vendor/symfony/http-kernel/HttpKernel.php(68): Symfony\\Component\\HttpKernel\\HttpKernel->handleRaw(Object(Symfony\\Component\\HttpFoundation\\Request), 1)\n#10 /var/www/html/vendor/symfony/http-kernel/Kernel.php(200): Symfony\\Component\\HttpKernel\\HttpKernel->handle(Object(Symfony\\Component\\HttpFoundation\\Request), 1, true)\n#11 /var/www/html/index.php(76): Symfony\\Component\\HttpKernel\\Kernel->handle(Object(Symfony\\Component\\HttpFoundation\\Request))\n#12 {main}”] [GET, /admin/store/plugin/api/install/1804/confirm, 126.208.165.144, http://example.com/admin/store/plugin, Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_6) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/87.0.4280.141 Safari/537.36]