新規インストールしたEC-CUBE3でcomposer updateするとよくあるエラー。

Fatal error: Interface ‘Pimple\ServiceProviderInterface’ not found in /Users/UMEBIUS/Dropbox/UMEBIUS Website/KOSHIN/vendor/knplabs/console-service-provider/Knp/Provider/ConsoleServiceProvider.php on line 14

Github公式にも書いておりますが、Silex1系に対してはv1.0を使わなくてはいけません。
なのに、EC-CUBE3のcomposer.jsonで@devと書かれているためv2.0を読み込んでしまうことが問題。
https://github.com/KnpLabs/ConsoleServiceProvider

なので、“knplabs/console-service-provider”: “1.0”,と修正してcomposer updateすると直ります。

ECCUBE制作トップへ

EC-CUBEカスタマイズに関するお問い合わせはこちら

    脆弱性修正