EC-CUBE4のプラグインを作っていてbin/consoleでアップデートしようとするとこのエラー。
[Semantical Error] Couldn’t find constant default, property Plugin\PopularProductBlocks\Entity\Config::$ranking_item_number.

Semantical Error!? 何のエラー!?と思ったのですが、Doctrineのエラー、@ORM\Columnアノテーションのoptionsでダブルクオート忘れてただけでした・・・。

@ORM\Column(type="integer", options={default: 90})

defaultをダブルクオートで囲む必要がありますね。

ECCUBE制作トップへ

EC-CUBEカスタマイズに関するお問い合わせはこちら

    脆弱性修正