EC-CUBEを勉強するためにSymfonyのどのバージョンを学べば良いかわからないという質問をいただいたので少し書かせていただきます。

EC-CUBEは各バージョンによってSymfonyのバージョンが異なりますが、確認方法はいくつか存在します。

Symfonyデバッグツールバーをみる

デバッグモードで表示されるSymfonyツールバーを見れば、Symfonyのバージョンが記載されています。

キャプチャの場合このEC-CUBEサイトのSymfonyのバージョンは4.4ということが分かります。

Symfonyのバージョン

composer.jsonをみる

composer.jsonやcomposer.lockを見ることでもSymfonyのバージョンが分かります。

“^4.4″という指定は、4.4以上4.5未満という意味なので、このEC-CUBEが採用しているSymfonyのバージョンは4.4になります。

composer.json

日本発!ECオープンプラットフォーム「EC-CUBE」 EC-CUBEゴールドパートナー EC-CUBEは株式会社イーシーキューブの商標です

EC-CUBEカスタマイズに関するお問い合わせはこちら


    [重要]現在公式にセキュリティサポートが切れていないPHPは8.1以上、MySQLは8.0以上で、対応しているEC-CUBEバージョンは4.2以上です。古いEC-CUBEを使っている方は適切なタイミングでバージョンアップをご検討ください。

    EC-CUBEバージョンアップ